Pls fix this broken thing

Tags: #<Tag:0x00007fca2084b6a0> #<Tag:0x00007fca2084b5d8> #<Tag:0x00007fca2084b510>

Today i have beaten Eyedol 3 times wasting a lot of resources…everytime at the end game crashes and when restart characters are dead…and makes you lose the battle…same goes for Sadira for the witch something…if i finnish her it crashes. This game has been around since windows 10 came out and still a lot of gamebreaking bugs…trying to unlock last lvl with beating gargos on challenging mode…i have done it ones and game crashed then to…pls fix this game mode. Its so anoying have to redo the same thing just to get a crash in the end.

/X

PS: As of now this seems to be bound to the challenging mode only.

DS: Game is still crashing if bound to challenging mode IDK but its crashing there!?

Out of curiosity, have you verified your game’s files or tried a re-install?

I have re-installed the game to a new harddrive so the files are “fresh”…how do you verify them? its on MS store not steam version btw. (Also tried setting it to start with admin rights no change.) Random crashes.

Info: Its very random and most times at the Emergency portals (with 3 opponents and against Eydol and scrolling through menu for unlocked sometimes it crash there to.) So its very random but i get 3 crashes aprox in one hour.

That’s weird; I’ve never heard of anyone else having this issue.

To verify your files on the Windows 10 version, go to Start Menu>Settings>Apps>Select Killer Instinct and click Advanced Options>Click Reset.

If that doesn’t resolve the issue, I’d next suggest uninstalling and doing a complete clean install, but you mentioned you already did so.

Alright well its not the first time this game has serious issues. (Atleast the Data is not getting wiped now.)

Ok i made a reset on both base game now and definitive edtion…lets see how this goes.

(I made both admin this time and this time it lasted much longer before crashing.)

PS: Still random crashes. So no luck. (Had one right now going up against Omen.)

So i played all day today on normal mode…without a single crash 50 turns:ish so idk if there has been a patch or its actually bound to challenging mode? Or might have got lucky this time? Well am going to try again and play the challenging mode again tomorrow and finnish up where things crashed.

/X

1 Like

There has been no new patch.

The game is no longer in development, so the PC version has not seen a patch since 2018, I think.

Ok yeah its still crashing but its weird it seem to be bound to challenging mode only…!?

If you keep experiencing issues, Xbox Support would be your official support, as the game is owned and maintained by Xbox Studios.

Alright well M$/Xbox wont be any help as usual…but ill try if i cant manage to beat gargos on challenging before it crashes again…8 crashes today in just a hour that must be a record. :stuck_out_tongue:

The thing is, for whatever reason, I suspect this is an issue with your system specifically.

I’ve not heard of a lot of complaints regarding crashes in Shadow Lords; certainly not to the extent that you’re experiencing.

Are you working here or you just answering this? Well there is nothing wrong here on my end…might be a specification issue with some of my hardware but i doubt it. I see you play the game on Xbox which i guess dont have the same issues since its the same hardware for all. (Might be the manual editing they did to my save.)

But there has been issues before with this game where peoples save got wiped and more so its not a individual problem. And also as mentioned this seem to be tied to the challenging mode only. But if you dont work here or have any other information helping here there really isnt any point in answering this unless you can pass the information forward. Thanks for your input tho and try to help. (Didnt know about reset in windows even tho it didnt help at all thx.)

Well there has been a lot of issues especially on PC what you heard is since you seem like a casual gamer dont really comply to anything (unless you do programing/patching etc.). But if you read in my posts from before you can see this has been a huge issue and they had to manually edit my save file etc. (Among many other users.)

Here are some refs to the old problems that might be part of the ongoing issue:

Another:

More on things that might be tied to this:

There is a lot on this issue that i posted in and other ppl to but ill share one more link in here:

(Can find more that might be related to the issues in my prev. postings replys etc.)

No, I’m not an employee, I’m simply a guy who tries to help people out :). I mostly play on PC, actually (Windows Store version), though I also play on my Xbox One X since it’s an Xbox Play Anywhere title.

Official support would be, to the best of my knowledge, Xbox Support.

And I suggest the issue is likely on your end simply because I haven’t seen others posting similar issues recently. All of your linked threads are from three and a half years ago. I can’t say this with 100% certainly, of course, but from my experience that’s usually the case.

I do hope you’re able to get your issue resolved.

Alright as i said am thankful for your input :slight_smile: but yeah its not really helping with the knowledge you have of what people complained about since there is prob. a lot with similiar issues just like back when the save issues where around…and i think there might be leftovers since then…becuse of the manual edit they did to save the stuff.

Oh ok i thought you played on xbox only (saw one of your gameplays which were on xbox thats why i assumed you played on xbox.) but yeah as i mentioned the save issue back then i think even tho even xbox users were affected were more PC users with issues.

Yeah i think i will have to do that…i tried to contact the guys / devs here which i was speaking to back then but still no answers. Could be someone sees this post and the related stuff posted to if lucky and get on with it.

Yeah on my end it might be the save file…but the issue would then be with others to since i wasnt the only one who got this fixed that way. But yeah maybe they dont play KI anymore or not Shadowlords? or long enough for the problem to appear? who knows…thats why i need someone with knowledge of latest patch and bug knowledge since last patch what is going on in here. (Although i do think its my save thats faulty to ofc i still think there are some bugs left in Shadow lords as well since i hear about crashes even tho not as much as mine as you say.) Yes its a old issue thats probably connected to what happend then…becuse the HDD is new and i dont have any crash issues with other games on that drive…i have another little thing here that actually got updated last night that might have been a culprit that has a lot of reported issues…which is the Dolby Acess for the Atmos app…(not that it has been set to on but yeah one thing installed can always lead to issues and since that one has been faulty a long time and i didnt see many crashes last night it might be part of the constant crashes even though as i said not active.)

Above is just thoughts i will have to see and try before i can speak for sure.

But there dont seem to be any devs around here anymore so i dont know if there really is any point in posting here…but if somone with similiar problem finds this it might be of some help or informative in the end. Who knows.

And yeah thanks hopefully it gets fixed…or i manage to beat gargos on the challenging and it actually sticks and stops crashing right after and i can just stop tearing my hair off so it can grow back again. haha JK but yeah it is getting anoying tho…

I will go and beat the ■■■■ out of gargos now hopefully one time and it sticks…cya

There aren’t, I’m afraid. The game is no longer in development, and Iron Galaxy’s contract is long done. On rare occasions someone who worked on the game has been here, but I haven’t seen him here in several months.

As the publisher, Xbox Support would be your best bet.

Having said that, I do hope you get the issue resolved, and if you do, please post back and let us all know what the fix was.