Definitive Edition Won't Run after recent Xbox Update (Help Please?)

Greetings, just wondering if I could get any insight on this if possible @developers & @moderators

So long story short the Xbox needed a reset, but after updating the system I tried popping in KI Definitive Edition only to see nothing was there. The thumbnail was visible, but selecting it shows absolutely nothing to install or launch. No characters, no packs, bupkis.

The Icon Registering the disc is in the system.

What’s supposed to be “35” items to install, but nothing is there.

I’ve tried multiple resets, deleted saved data and apps, but no such luck. But strangely enough, the disc for the Season 1 Combo Breaker Pack works just fine.

Installs Normally with 8 characters, the game and Combo Pack.

It even plays the game like it should.


Seeing how none of this occurred until just after I updated the console, I’m having a small hunch this could just be a glitch on Microsoft’s part. But what confuses me is why does the vanilla version work, and not the complete edition? They’re both literally the exact same game, except one just had more content to install than the other before start up.

Has anyone else encountered this, or am I just very unlucky at the moment? If so, any suggestions or methods I could try to get around this? Any advice on this would be much appreciated.

*Progress Update

While tinkering with the disc, I’ve received this message occasionally, however I’m still unable to launch anything.

Also submitted to Xbox Forums