World items in archives still not unlocking properly(?)

#1

Fortunately, the two Gargos cinematics unlocked properly after a couple of playthroughs in the 3.5 update. However two more seem to be locked, despite supposedly completing the tasks properly:

  1. Lore: The Hatchey’s Secret III
    I had posted about my issues with this one previously. I had played the preview and completed this quest line that earned the achievement and also the item. However, once the full SL release came out it was locked. I went through the painstaking Hatchery/stalker transceiver process in full, and it didn’t unlock. I also went through on a separate account (for which I didn’t complete it in preview) in the 3.4 version, completed the quest line, and got the achievement and the item. So, I assumed it was a glitch related to having earned it in the preview release.
    In 3.5, I went through the same laborious process again, completed the quest line that previously earned the achievement, and the item was never awarded again, thus still locked. Hopefully the devs can sort this out as I don’t think I can take doing that questline one more time as it seems even rarer for those missions to pop up now.

  2. Status: Titan’s Vengeance (update: Got this by resetting Eyedol’s story progress and playing through again)
    This one I’m not totally sure about in terms of requirements, but I completed the Eyedol quests to unlock him, plus I beat Gargos using him 15 times to unlock his mimic skin.
    Someone please let me know if I’m mistaken, and this is unlocked by some other means.

Thanks!

Bonus question (if the devs are reading this):
Will there be there any reward for getting 100% in the archives?

#2

Hatchery dossiers are unlocking normally, I’m still trying to figure out Titan’s Vengeance myself.

#3

The last Hatchery one has not for me as I described. (unless there’s something missing).

Please note in my description how it worked on a fresh account with the full release, but not on one where I got the associated achievement in the preview.

#4

I only recently got the Hatchery dossiers myself, it would suck if it’s a drop chance but I don’t think it is. It is a quest reward for picking the right option I think? I don’t remember what one I picked.

#5

Ok, thanks for the clarification. I’m wondering if it’s locked for anyone else who earned the Hatchery achievement in the preview. That’s the only thing I can think of as I’ve done the whole collect transceivers/get Wyvern-X/get security codes/get transceivers again/activate security console process more times than I care to count.

#6

Have you tried the outcome of blowing up the base? Maybe exhausting all the options might help. also received the achievement in the preview, so hopefully there is some kind of workaround. I would be disappointed from a completion standpoint.

#7

I haven’t re-tried with selecting the “bad” choices, but I’m so tired of the process, I was hoping the devs could clarify if it’s a bug.

#8

Well, when I get to that point again in shadow lords (I accidentally blew it up mashing “A” through text) I will let you know If I reach the same outcome. At least that way you know it’s not just you.

#9

I just completed the quest and did not receive the dossier. This was after selecting all available outcomes, so hopefully there is some kind of fix on the way because I’m all out of ideas at this point.

#10

Status: Titan’s Vengeance seems to be gone now unless I’m overlooking it.

Lore: The Hatchey’s Secret III
is still locked after the 3.6 update.

Can one of the devs step in and help clarify the status of this one or please help troubleshoot?

#11

Agreed. Especially now that unlocks are tied to dossier completion percentage. I would hate to have to start back at square one after getting to 75%.

Any and all help is greatly appreciated. Thank you.

#12

Titan’s Vengeance is now one of Eyedol’s character dossiers. Still haven’t gotten it yet, though.

As for The Hatchery’s Secret, it’s a little…weird. Trust me, I had trouble getting it too. Try using this guide.

#13

Thank you for the attempt, but I have the achievement and have tried every available story option associated with the quest. It isn’t a matter of completion at this point. It’s hopefully just a preview build issue that can point us in the right direction. Thanks again.

#14

@BlitzedKraig @TotalJimkata Can you provide any information on these two?
I know you don’t want to spoil anything, but do you know if they are working properly and if you’re investigating? It would be great to know of there are actually potential issues as we assume, or if we are missing something. Aside from some character dossiers I’m still waiting on to pop up, and those locked due to unreleased content, these seem like the only legit unattainable ones. Happy to provide any play info needed.

#15

You can reset quest lines from somewhere apparently, redo the Eyedol quest line and you should unlock it.
The Hatchery dossier, you’re probably not gonna get it in a single attempt. The only advice here to is to keep powering through that quest line q(deploy or use the minimum necessary items to beat it) and it will unlock at random. Its unlocked for me, the only one I’m missing is one of the Umbral Militia ones.

#16

I don’t want to reset anything unless I have to. I have too much progress.

Also, as I noted earlier, I have completed the Hatchery quest line many times. I can’t get it to re-unlock since the update to the preview build when I got it earlier.

#17

You only reset the questline, the dossiers stay unlocked.

#18

What about the progress meter?

#19

The progress meter depends on the Archives you unlocked, and since nothing happens to them, nothing happens to the Progress meter.

#20

How do you reset the questline for the hatchery? It still regularly shows up. The Eyedol one I get, but the hatchery one, if you could please explain this. Thank you.