Troubleshooting for Killer Instinct Anniversary Edition - Patches 3.11.15, 3.11.16 & 3.11.18

Steam - Windows 8.1
Sync for 30 seconds
Always fail to sync and repeat

Thank you

Sending you a message

I was helped by support to resolve this issue. Apparently it is an OS level issue that is being caused by updates to Windows not removing an old instance of GameInput service when installing the current version, causing your system to run both simultaneously. I was directed to a Reddit thread to resolve the issue manually, but it is not a simple fix for the masses and requires some decent knowledge of computing to implement, so follow at your own risk:
https://www.reddit.com/r/WindowsHelp/comments/18bb6e0/gameinput_service_stops_working_after_windows_11/

Game seems to be working fine now. Hopefully this fix can help anyone else running into this issue.

1 Like

I’d like to mention somethings that are happening with Win10 PC. #1 This first one happens while logging into Ranked multiplayer (at times). It’s happened to me at least twice now(maybe 3 or 4 times?), where I’ll be done with a session and close the program (usually a full exit through the menu’s) and then the next time I go to log in I’ll be credited with a loss due to disconnect? Here is a clip of this. ( Twitch ) #2 Next, I have recently tried to do a survival(classic) run to unlock achievements I should have unlocked long ago, but for whatever reason even after completing I’m not credited and the achievement doesn’t unlock. (I assume it’s because I exited after the final match instead of dying?) I do remember trying a few of these runs before years ago, not having the achievements unlock and ultimately moving on. Here is a video of the end of the 10th, and the 11th fight of my most recent survival playthrough ( Twitch ) That’s all I got for now. Thanks for reading!

Oh, there was one other thing I’d like to mention or ask. Is there anything that can be done about Japanese hiragana/katakana/ kanji being displayed as boxes on the Eng version of the game and a blank name in game? It doesn’t seem to matter if I’m using steam, win10, or xb1 versions, all of them display these characters like this. Just want to know who some of these players are without having to track them down on Japanese streams(when I’m lucky enough to find them :P)

Thanks for posting this! Passing on to the team.

1 Like

Hello there,

I don’t know if this is the good place, but I’ll speak here. I made a compilation of glitches that I found recently while playing KI. I don’t know if all of this situations are glitches or if this is normal, but I hope this helps the dev team.

1 Like

I’m having the same problem as many. Initial load into white screen into black screen into crash.
I’ve tried a few fixes I’ve found with not success…

This happens only on Xbox for Windows version. I just installed on Steam and it’s fine there but I do not have the Anniversary Edition there :frowning: If theres a way to link the accounts, I’m glad to just play on Steam

Some solution for this?

I want to play please solve this sync issue

Been trying to play the game for a few days now having same problem on my Xbox one x and my Xbox series x…… sync timeout after 30 seconds continue times out again and then instantly puts this on the screen

Sending a message


I keep having an issue on Xbox where all of my wins are erased. The win/loss ratio updates, but nothing else. I’ll accrue a ton of points, but I notice I don’t move up the latter. If I log out and log back all history of my wins is lost.

Error Loading Save File
You will be unable to save/load game progress. Error Code: 10

Don’t know if related, but corrupted save may have been linked to me experiencing this earlier:
Killer Instinct crashes on startup on Windows 11 - #4 by Drenghel

Thanks a bunch ! Not sure if related to this version, this place just seems more appropriate

=> Solved Troubleshooting for Killer Instinct Anniversary Edition - Patch 3.11.15 & 3.11.16 - #37 by Drenghel)

If you are crashing on Win11, please see this post above: Troubleshooting for Killer Instinct Anniversary Edition - Patch 3.11.15 & 3.11.16 - #23 by EligibleHat48

Will send you a message to help troubleshoot further.

I’m no longer crashing thanks to the link I provided (the same you just gave too)

Edit: Rebooted a few times and progress came back, DONT pick “use offline data” that’s how saves get replaced

1 Like

FIXED BLACK SCREEN CRASH ISSUE

With some digging around and the help of James (as UltraSupport), we found there was a problem with the game accessing the GameInput services… because they weren’t there.
I figured out that my Windows 11 was locked in 21H2 version but said it had no updates available as if everything was fine. Turns out that since 22H1 you need to have a TPM 2.0 compatible motherboard; I do, but the option that enables 2.0 is disabled by default on my mobo (B550 Gaming X V2) so I needed to activate an option in BIOS in order to update to 23H2 which immediately fixed the problem.

Here is a quick guide on how to check if this is the cause for your crashes:
1 - Right click the Windows icon on the task bar and select System.
2 - Under Windows Specifications section you can see Version (in my case it was 21H2)
3 - Go to Windows Update and check if Updates are available. If so then updating should fix it.
4 - If not able to update, download the latest Win 11 instalation ISO at Download Windows 11
5 - Open up the setup.exe and try to update. If you get an error that it cannot perform the update because TPM 2.0 isn’t enabled, then you need to check your motherboard’s manual. It might not have it at all if it’s pretty old or, as in my case, there might be an option in BIOS to enable it. If so, enable it and run the setup again.

Game should start working immediately after the update to the latest version of Win 11!

1 Like

@UltraSupport Found some issues playing Anniversary Edition on Original XBOX ONE unit. (HALO 5 model to be exact.) And yes, the system has been updated to its recent version as of this writting.

  1. Game Crashes after picking Mira’s retro costume in Offline Versus mode(CPU) Only happens with her Retro costume for some reason.

  2. Mira’s Jester Retro costume also has a flickering issue. Something with her accessories are completely bugged. This happens during in-game fights as well, which is really distracting.

What its supposed to look like)

What it looks like on my Xbox One Original)

Furthermore, somethings also effected her Nightwalker accessories, as her skirt also flickers and changes colors when its not supposed to. Even glows depending on which accessory I pick, which is not supposed to happen.

  1. TJ Combo has a bug on the Training stage (Practice Mode in my case), for some reason the lighting goes darker whenever he’s player 2. Not when he’s player 1. Something with the game’s lighting system must’ve gotten borked during the updates. It also shows up on the Steam Version too.

What its supposed to look like)

What it looks like on Xbox One Original and Steam)

  1. Plasma Jago/Shadow Jago? This happens when I simply hover the curser over the mimic skin right after going into Vs Mode. It goes away afterwards, but still, what even is this?? Pretty sure the game isn’t supposed to be doing that…

  1. This last one occurred during a battle in lobby mode, but still pretty strange. Kan Ra’s stage suddenly had red and blue stripes all over, looking like Wheres Waldo came to visit. It only happened to me once, but this should definitely be looked at if possible.

  1. A more concerning issue I’ve experienced, the game seems to run noticeably slower in the Main Menus. Before the update everything was reasonably fast, but now the game takes much longer to load anything on the older console. Often times even causing the game to crash all together. This should not be happening.

If we could get updates that don’t potentially break the game any further, that would be greatly appreciated. The game was working perfectly fine before any of the Anniversary updates.

Really wished the playerbase wasn’t treated like a second rate Q/A team, but frankly I would just like the game’s issues resolved if possible.

Thank you for the detailed breakdown of all the issues. This is James Goddard writing from the support account, I want you to know that we do appreciate when people take the time to report issues and provide this kind of detailed info.

1 Like

Still not working still no help