Troubleshooting for Killer Instinct Anniversary Edition - Patch 3.11.14

Thank you for reporting. We will investigate this.

Hey there, thanks for the info! I tried looking into the details tab and the processes tab but couldn’t find KI anywhere after closing the windows 10 copy. It’s weird it’s specifically this version, as the steam version is working just fine atm. What you say makes sense cause after a restart of my computer everything is fine again.

Whenever I load up the game it doesn’t even get to the Microsoft logo, it closes on a white then black screen. Tried uninstalling and reinstalling, didn’t work. Got a fix in mind?


We’re sorry to hear you’re experiencing this issue. We’re going to reach out through direct message to ask a few questions and gather more info to try and help.

Hello do u have some news about this issue?
Thank you very much

The issue that i was seeing during the ranked cross play beta of the game freezing for a few seconds I have seen again. This time on steam playing against xbox/win10 players in exhibition. During the beta it was on xcloud/xbox against steam players. Doesn’t effect game play as it only seems to happen during times of round transitions or ultimates.

Not sure if it’s possible but it would be great to have the option of having the old cinematics on Xbox Series to save space. The 37GB difference between the PC and Xbox version is a lot.

Hi, AlexV Here

I’ve had this issue since the latest patch without any prior issues for years, Windows Version of the game cannot start and just crashes before anything can happen.

Tried all the usual, uninstalling, verify and repairing, administrator, all the available Windows and Nvidia updates.

Any ideas on how to fix it? Thanks!

AMD Ryzen 9 7945HX
Nvidia 4070 @ 8GB - latest update
64 GB DDR4
Windows 11 - latest available update

Hi AlexV,

I’ll reply to you in a direct message and see if we can figure out what’s going on.


Thank you for this feedback! I will pass this request along to our team.

Two bugs:
With FSR turned on at 1080P on PC, on the character selection screen, review the full body version of Rash (look at his smile). It almost is a moire effect.

If I turn off FSR, it is back on the next time I load the game.

Report received, thank you for sharing. We’ll add this to our bug list to look into.

I, like several other people in this thread, am running into the issue of the game crashing on boot. The game seems to load fine but instead of loading the videos for the Iron Galaxy and Microsoft logos, it immediately closes the program and crashes to desktop with no error message displayed.
I’ve tried completely uninstalling and reinstalling and rebooting my system, but no error message is ever given and the game refuses to launch in any way.
It was working when I last played the game about a month ago, but I do recall a similar issue happening on my old machine a number of years ago, and, finding no public resolution to the problem available, just uninstalled the game.
I’ve played it a handful of times on my new system without issue until now.
No other software on my machine is having this issue.
Windows Store version, using Windows 11.

1 Like