Stuck in DLC Timeout Screen

After updating to 3.5 version on Windows 10, the game worked. but today I am getting this screen and cant get passed it. I have been waiting and retrying for 30 minutes.

Anyone else have this issue?

Have you hard booted your pc?

Yes i restarted.a few times already.

I having this issue on the Xbox now

same here. :rage:
no problems for my son’s account.

I want to play SL with Eyedol :sob:

I’m having this issue on PC as well. Last night I had no problems at all, but then it started to do this morning. My KI Gold is missing and I can’t access Shadow Lords at all.

Same here. I think its a Xbox live problem. A lot of people complaining here

1 Like

You’re right. It seems it’s an Xbox Live issue altogether:

Many other games are being affected as well.

1 Like

it seems a DDS attack against xbox live. Old accounts are suffering the most.

I’ve been having this issue on Xbox. Strange, because Xbox LIVE still seems perfectly functional. Both Network and Multiplayer connection tests worked well, other games are working fine…
This is weird. It makes me sad when I can’t play the game I love so much, whether it be bugs or DDOS attacks or what have you… :sob:

Yeah, also having this issue on my Xbox.

Why can’t people find better things to do with their lives than try to make others a little crappier? Seems like a lot of work for minimal payout.

Just curious, but would this also follow under the line of any DDOS attack on Xbox?

Happened to me yesterday.

I’m on PC having the same issue.

Same problem, also I can’t connect to Overwatch or The elder scrolls online which sucks because I wanted to try it while its free to play…

guys just press continue it still saves your characters roster and accessories

Can’t play Shadow Lords. :\

lol i could never played shadow lords after the patch soo its nothing diferent :slight_smile:

Same here. When eventually choosing the skip/continue option
I am unable to start Shadow Lords (says I’m not connected to LIVE,
even though the game shows me logged in) and the season 2 cast
is unavailable for play. PC version by the way, haven’t checked on X1.

EDIT: whatever the issue was, it seems to be resolved by now. :slight_smile:

I skipped the Checking DLC. All my stuff was still there (including my Shadow Skin and Player Rank, thankfully), but I could not access Shadow Lords. Which is annoying because I was right at the end of the Eyedol quest last I left off… :frowning:

Same here. I skipped it though; was stI’ll able to play in the Shadow Lab however.