(Please Help) Failed to Connect to Multiplayer Servers

Windows 10
Every time i try to play Ranked and Exibition i get this message. But i can play shadow labs just fine. Talked to Microsoft support and after there solutions did not work they said to come here and that it is a game side server issue. I have tried every fix i could find ( Teredo Adapter, Port Forward Xbox live, reinstalled game, reinstalled windows 10) still getting the same message if anyone knows a way to fix this please help been at it for 2 days now.
In the Xbox app under Network status it says Teredo: Obtained, Xbox Live Services: Up and running, Packet loss: 0% and Latency: 81 ms

Same happening to me. I was playing fine until tuesday. Now the game cannot find the matchmaking servers since wednesday. Please fix this! I have a local championship to participate on sunday! :scream:
Teredo, IPv6 and everything else is ok here. Maybe, my IP range was blocked by accident?

Which country are you from Aradroth2?

when i couldn’t join ranked, i went into xbox network settings. Have to make sure NAT type is open.

Also, there’s some other setting there, that i can’t remember, that can soemtimes have a value (for most people, it shouldn’t).

everything looked fine, so i ended up doing a hard reboot of the machien and all was fine.

the few times its happened, the hard reset after retesting internet connection seems to be ok .

maybe look up details of the options in the netwrok settings. do whatever you can and then do a full reboot?

im US East

how do you check your IPv6?

There is a website called test-ipv6 dot com

Try this, it worked for me:

Just go to Device Manager -> View -> Show hidden devices
Uninstall Teredo Tunneling Pseudo-Interface (don’t worry, it will come back again)
Open a command prompt (Run as administrator)
Then type the following commands:
netsh int teredo set state disable
netsh interface teredo set state type=client

Confirm that IPv6 is working by typing:
netsh int teredo show state

If the “State” says “qualified” try to open Killer Instinct again and go multiplayer.

I hope it helps.

ok did what you said got the Teredo Tunneling Pseudo Interface back also under "show state it does say qualified. I also went to that site (test-ipv6.com) and it said 10/10 ready. still not working.also my teredo address in the app has always said obtained. i noticed in the cmd for netsh int teredo show state it says under NAT restricted (port) how do i fix that and could that be the problem cause everything else is working like it should. Also thank you for the help man i just dont know what to do at this point

This is my netsh output.

Do you have UPNP: Yes?

If not, try to turn on UPNP or put your local IP in a DMZ. You can do this on your DSL Modem or Router.

Also try this:

Go to start type run then in run type services.msc go to ip helper right click then properties and make it automatic then press on start the service , if it’s already started then click on restart service.

ok the service was already on automatic so i restarted it. Also on the UPNP mine says “No” how do i turn it on?

this is what mine shows
Type : client
Server Name : win10.ipv6.microsoft.com.
Client Refresh Interval : 30 seconds
Client Port : unspecified
State : qualified
Client Type : teredo host-specific relay
Network : unmanaged
NAT : restricted (port)
NAT Special Behaviour : UPNP: No, PortPreserving: Yes

Access your modem or router configuration page. You can do this by going to your web browser and typing the IP address of the device for example: or then you login with the admin and password of your router and there search for an option called “UPNP” and switch it to “On” or “Enabled”. I cannot help you to configure this because the process can be different for each brand of router/modem in the market, and there are many of them. Maybe if you send me the brand and model of the router I can send you a few screens that can help. But do this in private message.