Official KI Bug Reporting Thread Season 3

Keits I beg of you…please just give Kim a forward advancing shadow counter and be done with this madness :’( (…and yes this is the 3.1 update)!106910&authkey=!AE6DCaEsMDW_yOg&ithint=video%2Cmp4

1 Like

this isn’t exactly a bug, it’s a much bigger issue. sinse the update, I can no longer use any character from season 2 or 3!!! I paid for the double combo bundle, and the combo breaker bundle. I have already tried uninstalling, re downloading, and reinstalling. To no avail. any help with this issue would be greatly appreciated. I kinda feel like I got shamed here to be honest

Still no info on the not reaching matchmaking servers bug? I’ve tried every possible fix and nothing has worked. It’s been a month now and I can’t play online.

Last night I encountered my very first crash during online play. I’m pretty sure it’s a multiplayer bug, not sure if it can be reproduced, but I’ll explain how it happened:

Joined a lobby (was third in the line and watched two players fight).
During their match, it disconnected (possibly because of me being in Africa) and gave the usual “Press A to return to Menu” or something like that.
I was busy with something so didn’t press “A”.
Suddenly, a match started out of nowhere between me and someone else, without the character select screen coming up.
For some reason I was Thunder.
After losing the match, the game crashed at the victory screen.

I’m on Windows 10 running a AMD FX-8150 with a AMD HD 7870 and 8 GB RAM.

Basically, I think not pressing “A” after disconnecting from the lobby causes the issue.

hey!! just fix WIN10 vesion rankedmatch crash!! this is siriously problem!! bro!!

A few bugs:

  • Mira’s default accessory sets (or parts of them) do not change colour for the different colours. She always has a red cloak in her modern look and purple and black boots in her retro.

  • the timing for breaking the fourth hit of Maya’s seems weird. If you try to break hits 3 & 4 and press it as fast as you did previously or as you do with hits 1 & 2 then you will often get a lockout or nothing come out. However if you delay the break in the fourth hit slightly it comes put fine. It seems the break window on the fourth hit has been delayed a bit (although the breaker icons seem to be at the normal time). You can actually break all 3 last hits with an even (or at least almost even) rather than 1-2-pause-3.

  • Glacius’ shadow cold should is fully invulnerable before the freeze during startup. After the freeze it reverts to projectile and lower body invulnerability.

1 Like

As of today, I’m getting “Failed to refresh DLC content” and can only play offline now.

What’s going on?

I too am experiencing the "“Failed to refresh DLC content” error.

Plus, I’m unable to see Mira’s retro costume since the game crashes and goes back to the Windows Desktop.

My specs below:

OS Name Microsoft Windows 10 Home
Version 10.0.10586 Build 10586
System Model Alienware X51 R2
System Type x64-based PC
Processor Intel® Core™ i7-4770 CPU @ 3.40GHz, 3401 Mhz, 4 Core(s), 8 Logical
Installed Physical Memory (RAM) 8.00 GB
Adapter Description NVIDIA GeForce GTX 970

Tried the wsreset command, waited for the Windows Store to boot up and restarted my PC. No luck

In the windows 10 version, both my friend and I are unable to continue with dojo lesson 16, as when I use a controller it says “invalid text” at the bottom of the screen and won’t let me continue (even though all of the other buttons work ie. frame advance, half speed,etc), and when I use the keyboard, the ESC key doesn’t work.

Anybody else able to skip the demonstration in dojo lesson 16 on Windows?

1 Like

I’m getting this right now and another community member is getting the same right now. They posted in this thread;

Anyone else getting this currently?

For Aganos his walls take a hit point if he hits the opponent with Jumping HP on regular characters. Haven’t seen anything else that takes a point off it as of now

I have got AWEFUL tearing despite Vsync turn ON (Nvidia)

Geforce GTX 750ti
Drivers version : 364.72

This is so freaking frustrating.
I have this exact same issue playing on PC.
I can’t skip demonstration mode in the dojo lesson 16.
All the buttons works except for the ESCAPE button on the keyboard which apparantly does nothing.
I even tried lesson 17 and it has the same issue of not being able to skip the demonstration.
The esacape buttons works fine in the menu and in local play, it’s just in demonstration mode that it doesn’t work.

Once you’ve entered the lesson, the only way to get out is to close and relaunch KI.
Please fix q.q


Reproduction steps for the Dev team:

1: Launch KI on PC.
2: Go into single player -> Master -> Dojo.
3: Select lesson 16.
4: Attempt to get out of DEMONSTRATION MODE using the ESC key.

Ever since the Mira update teching throws has been off, namely that it doesn’t create much distance. Maybe it’s just with Mira but it’ll often happen where in the corner after teching a throw both characters will still be within jab range of each other.

Also got some iffy combo breaker spacing, as after a breaker against saberwulf I was able to follow-up with a normal before the opponent hit the ground and combo. This was from playing offline.

I posted about this earlier in another thread, but it seems I might have gone to the wrong one, so I came here to the proper bug report thread instead.

My issue is this…
Since the Mira update I can’t use any characters beyond season 1. I tried re-installing the game, and someone also suggested making sure my time zone settings were correct, so I tried doing that (both manual and automatic) but nothing changed.

If I try to buy any of the other season packs it says I already own the Supreme Edition, if I select the latter nothing happens. Also, whatever pressing Y does on the main menu, it doesn’t work. Other than that it seems the game runs fine.

I am a bit sad that I can’t use Mira though, because I’ve had an extremely rough week and I was really looking forward to playing her this weekend.

If anyone has suggestions for a solution or work-around, you’re a superhero in my book!

Oh yeah, it was suggested that I tag @rukizzel too.

I’ve noticed Sadiras Assassins disappear on her stage. Anybody else notice this?

In single player, Fight Archive doesn’t work properly as its menu screen randomly disappears. Game needs to be reset to resume play.

  1. Go into Fight Archive of Single Player mode
  2. Menu doesn’t appear. This happens randomly. Pressing any buttons doesn’t work (A or B) even though “back” is displayed at the bottom.

Just got a crash on Win10 playing Online Ranked as Mira vs Arbiter. It was right after I did my command grab ender in the first round. First time I’ve had the game crash mid-game like that.

Its because they’re sneaking up behind you.

Update on the glitch that makes it so only Season 1 characters work.

So, I didn’t notice at first, but it seems the game think it’s Christmas as there are holiday items to be found in the store. I once again tried to fiddle with my region/date/time settings to make Killer Instinct realize what time it is, to no avail.

EDIT: I also tried signing in manually while the game was booting up, changing the store region, syncing my data twice, buying some items in the store using gold, grabbing some achievements (they have the correct time and date added to them according to my live account) and even got another game from the Microsoft store itself in order to make Killer Instinct “snap out” of the belief that it’s Christmas 2014. Nothing worked so far.

EDIT: I thought daylight savings had something to do with it but I realized I was looking at the wrong dates.

My guess is that the glitch is happening because the game somehow lost track of time because of this and somehow the DRM got affected too and screwed up.