Wont start up (Win7)

Was super hyped when I found out the game was suddenly on Steam. And especially that it would run under Win7. Or at least is supposed to. :slightly_smiling_face:

When I start it through the shortcut or from within Steam, nothing happens. Steam tells me its preparing to start the game. That window disappears and thats it.
So I started it directly from the install directory and this is what happens:

Im well above the minimum requirements. Latest graphic driver installed.
Anyone else running into this? Any ideas? Cheers!

Please install the required libraries for the game to launch, they are in that _CommonRedist folder

let me know if that helped you :slight_smile:

Hmm… Dx11 no problems.
vc redistributable doesnt really wanna do anything though. I had the option to update. Which I tried, but it failed. So i uninstalled completely and tried to re-install, but failed again. I ll post the log below.
Tracking down that error message on google led me to a post by some microsoft employee, suggesting to manually install the msu. When I attempt to do that it’s telling me that the update is not the correct one for my computer.

Trying a windows update right now. Seems like I didnt have Service Pack 1 installed.
Okay the update just failed. I ll see if I can get this fixed. Could imagine that might be the issue.
I ll keep you up to date. :slight_smile:


Hmm… clearly something is missing from your system.

Well… after screwing around with Windows Updates for more than 30 minutes I decided it is not worth it. And by that I mean I decided it is not worth it to not re-install the OS. So I did that, installed all the Windows updates and all the recent drivers and everything and downloaded the 30 gigs again and what happens??
The game starts just fine. After playing for an hour I can finally go to bed with a happy face.

Thank you very much and good night! :wink: