Ultimates not working?

For some reasons I can’t get the Ultimates to work. Yes, I have downloaded them. Yes, I know how to do them “I have been doing Shadow Jago’s for quite a while now” for some reasons I can’t get them to start. I have tried all 5 new characters, and none of them work. I even went back to Shadow Jago, and now I can’t get his to work either.

Am I the only one?

Getting a supreme victory?.. activiting an Ultra? Then quickly press LP and LK together? (Have to press it with in the first few hits of the ultra or it doesn’t activate)

same with me

you have to activate it after the ultra???

Yup. Go in to Ultra then press LP and LK

thats annoying lol no joke

From my understanding, it has to be done immediately after an ultra opposed to midcombo/ultra cancel like you could with Shago.

I haven’t tried myself, so I cannot say for sure.

Thank you everyone for replying so fast :smile:

I got it down now. It was the ultra cancel into ultimate that was throwing me off.

It feels like another “change for the sake of change”. Why it wasn’t left alone a la Shadow Jago’s Ultimate input is beyond me.

Here’s an example video of Maya’s Ultimate. You see the Ultra kick in first, then the Ultimate animation.

Could be because of issues with the existing characters or to prevent people from overdoing it. Not sure, but I enjoyed the way Shago was able to do his, separate input without being locked on the start up of an Ultra.

The precedent was set with Shadow Jago’s Ultimate and just makes logical se…oh never mind. I see why the change was done. Kappa