Still Having Trouble With Ultratech Servers

I have the Definitive Edition on the Microsoft Store.
Booting up the game gets me past the title screen but keeps me stuck on Syncing to Ultratech Servers - Checking DLC & Syncing Shadows.
I uninstalled and reinstalled the game, but it didn’t change anything.
I’ve seen others online with this problem claim it’s a problem with Microsoft and their servers, but those complaints come from January. At this point, I don’t even care if I can’t play online, I just want to be able to actually play the game. Any help?

I’ve noticed this problem recently, where it’ll be stuck forever, which is different from the old issue.

I close the game, sign out on the Xbox app, and open the game again and let it sign me in. Then , it works

Firstly, welcome to the community!

I haven’t had this issue myself yet, but I’m wondering if it has something to do with your NAT setting. From your desktop, go to Start Menu>Settings>Gaming>Xbox Networking .

What does it say? Does it pass? Does it mention Teredo not qualifying?

You’re right - Teredo doesn’t qualify. I can click the “fix it” button, and it will, but it doesn’t let the game run, and resetting the computer will make it go back to not qualifying.

Okay, here’s an Xbox Support article that may help you. You’ve already tried Solution 1 and 2, so you’ll want to jump to Solution 3.

If that doesn’t work, you’ll likely need to do port forwarding. Here’s an Xbox Support article listing the ports you should forward.

This site is a wonderful resource on how to actual forward your ports, the Xbox Support article above is just to reference the one’s you need to. You’ll need to find your specific modem/router on portforward.com, and follow it’s instructions.

Hope this helps!