Resolution problems

#1

I am experiencing problems with the Steam version of KI. Every time I load the game, the resolution is set to 640x480 and I am unable to change it.

I must set the game to windowed mode, exit the game, then restart in order to get the option to change my resolution to 2560x1440. Every single time. As soon as I complete a game session at 1440, I will have to complete the above process every time I restart the game.

This is something that will certainly turn me off to the Steam version. I do not experience this problem with the Win10 version.

Intel i7-7700 cpu
16GB RAM
GTX 1080 video
Win10

#2

I also have resolution Problems. I have a 21:9 Monitor (3840 x 1600) And I want to play the game in 16:9 with black bars on the side. But when I select any 16:9 resolution, the game only displays on something like a square. When I start the game in full screen, many resolution options are missing.

I also own the windows store version and it works without problems.

1 Like
#3

Open this file in notepad after setting the resolution in the game
default_pc.cfg (located in the steam games Killer Instinct folder)

there maybe a setting you can change to have a preferred resolution, at the moment i am still downloading the game so i cant help further but there also might be some KI game folder in the documents folder

#4

I already searched the config files. But can’t find any resolution data.

#5

I will try to find a setting once the game has finished installing. Check your Documents\My Games folder. usually setting files are inside those folders or maybe in some folder in the %appdata% Local or roaming folder

#6

We are trying to chase this down. At least to see what it is.

1 Like
#7

One more thing - could I please ask what your resolution is set at on your desktop? As well as the native resolution on your monitor.

Thanks!

#8

Desktop is 2560x1440 which is also my monitor resolution.

#9

Having the exact same trouble on my PG278QR. 2560x1440.

It worked fine the first time I loaded the game, but subsequent loads have locked me at 640x3something.

1 Like
#10

This seems relevant. I am also using PG278QR display.

Edit - ASUS ROG 1440p G-SYNC monitor

#11

Yep. Same monitor.

#12

Interesting stuff. While I will be the one responding, know this thread is being watched. Don’t know of the status yet, but I know folks are on it.

#13

I have found a temporary solution for the resolution not being saved.

Make sure to set the Fullscreen mode to Borderless

1 Like
#14

Ok thanks, I got it working:

-The game startet in Fullscreen, max. selectable resolution was 1920 x 1080
-switched to windowed, restarted the game.
-my desired resolution (2844 x 1600) was selectable…
-switched to borderless
-game displays in correct aspect and resolution is stored

#15

Glad I could help, hopefully this bug will be fixed soon

#16

Ki laggin really bad i have to set my Res to 1280. Why can’t i play on 1920x1280

#17

For the folks seeing issues with their resolution, there was a fix pushed out not too long ago. Please restart your game client and let me know if things are resolved.

Thanks!

#18

Resolution is no longer resetting

#19

Confirmed I am no longer experiencing these resolution problems.

#20

yeah, that fixed it. another thing, could you guys look into adding support for DSR (Dynamic Super Resolution)? I like to use it in some games to get better anti-aliasing but Killer Instinct only seems to acknowledge the native resolution and those below.

I have a BenQ XL2430, its native resolution is 1920x1080. DSR in the Nvidia driver settings enables resolutions like 2560x1440, 2880x1620 and 3840x2160. but 1080p is the max setting I can pick in the graphic settings of the game.

edit: well, was there a patch already? either way, it works now. can select 1440p and 2160p. I guess 1620p is not supported?