Recording Killer Instinct on Windows 10

For the past few days, I have been trying to find the best way to record Killer Instinct exclusively on Windows 10. Gamebar support is not yet implemented so I put together a little video to help anyone who was having a similar issue trying to get quality footage of the game. I hope this helps. Just click the hyperlink below and it should bring you to the video.

How to Record Killer Instinct Footage on Windows 10 - UsefulMagikarp

1 Like

How can you record with shadowplay? ‘-’

Mine doesn’t recognize KI. :frowning:

Like I said in the video, you want Shadowplay to be capturing your desktop, not the game itself. If you go into preferences in NVIDIA Experience, there will be an option to allow for desktop capturing. Then just turn that on! Simple as that!

i don’t have this button on Shadowplay’ options x)

You should be seeing this option in the NVIDIA Geforce Experience Application

thats what i said: the button isn’t here lol

Have you updated to the latest version of the application? I think it’s a relatively new feature they added.

i’ll try to reinstall

Edit: still the same problem with the latest version.

Try installing these Beta drivers and see if that works

Same ere…Windows 10 Game Bar support should work for this game as its apart of the UWP!!! Iron Galaxy need to fix this asap as i know it works fine using Gears of War UE!!

OK. I have the lastest driver for nivdia. same for Geforce experience.
But i still didnt see the monitor button :/.

I tried to use OBS, but due to laptops dual GPU, it result to a black screen for w/e game i record, so bye OBS.
tried xplit. it doesn’t recognize KI xD.

Edit: Tried a new tips for OBS. IT works! thanks sir :).
But i have some fps drop.

I’m glad that you could get something working!