PC Port - Game Speed is Way Too Fast

I just downloaded this on PC and first thing I have noticed right off the bat is that when I enter a match, everything seems to be in fast forward. On the main page to the game it says to go to ultra-combo.com for a workaround, but I haven’t been able to find it yet. Can anyone help me out?

I’m assuming you have a >60hz monitor.

For Nvidia cards:

Right-click on desktop -> NVIDIA control panel -> change resolution -> make sure it’s set to 60hz

If you have windowed n-sync enabled, you may want to disable it.

If you’re on AMD, the process is similar, just not the exact same names.

Essentially, turn your refresh down to 60 and you should be good. We’re working on a built-in solution that’s coming soon.

if you have a high refresh display you need to force your mointer to run at 60htz

This post was flagged by the community and is temporarily hidden.

It’s worth mentioning that the setting in question on the Nvidia Control Panel is oddly hidden above the typical settings, which isn’t immediately apparent.

The typical settings (for my 144 monitor, anyway) include two categories: HDTV and PC. Normally it’s on PC, because that’s where the 144 Hz option is, but if you go to lower the refresh rate in any resolution, it only bottoms-out at 75 Hz with no option to go below that, which is still too fast.

Above all of that, though, are the HDTV options. Those all are on 60 Hz by default, and that fixes the speed problem.

It’s still a pain to need to change that option every time I want to enter the game, but that’s the easiest workaround I know of. I was never able to find a way to create a GPU profile for the game that included refresh rate. It has a lot of options, but refresh rate is not one of them.

Having my monitor set to 60 Hz causes me to have headaches, so I will need to change refresh rate every time I want to play KI, And its a pain in the butt hole like @entrypulse said.

since Windows 10 setting the refresh rate using the AMD radeon-crimson driver has become a little convoluted.

I found the best reliable way to set the monitor refresh rate in Windows 10 is to:

  • Right click on a empty area on desktop - Select desktop settings
  • Scroll down and select - Advanced display settings
  • Scroll down and select - Display adapter properties
  • Left click on the Monitor tab - There you will see where to select and set your monitor refresh rate
    also under the Adapter tab - You will see - List All Modes

To make things a little faster you could make a shortcut to [Control Panel\All Control Panel Items\Display\Screen Resolution]:

  • Right click on a empty area on desktop, Go to New and click on Shortcut
  • You will see a Box pop up saying [Type the location of the item], Copy an Paste or type in this:
    rundll32.exe shell32.dll,Control_RunDLL desk.cpl
  • Then click next
  • You will see a Box pop up saying [Type a name for this shortcut] Type any name you like i.e. Display settings
  • Now you can just Double click the shortcut - Then click on Advanced settings to change your monitor refresh rate settings a little faster.

Hope this helps out a little until they fix this problem ingame.
Peace out

May I ask who’s bright idea it was to bind the frame rate to the game logic? The very notation of someone insinuating that I should lower the refresh rate of my monitor to play this singular game properly is so barbaric that it isn’t even worth the time spent to conceive such madness.

you have a good pc? because for me… o man… i dont wanna play in a Xbox anymore lol