My Xbox 360 Street Fighter IV Fight Pad doesn't work anymore

After Updating to Shadow Lords, My Xbox Street Fighter IV Fight Pad doesn’t work anymore. The game does not detect it at all even though Windows 10 does. It worked perfectly in the game before.

At the top of the screen, the Controller icon is grayed out.

1 Like

same thing happened to me but haven’t gotten any word back from anyone for over a month to fix it. Which sucks because i really want to play the game but can’t


(My speculation) I think it has something to do with the Anniversary Update to Win10. They updated the software to allow for Xbox One accessories, but it seems they may have cut the 360 accessories. If I were you, I search for 360 stick/controller dirvers and see what is out there.

Sorry I have nothing official to offer. Maybe you could contact some of the MS guys on here directly?

The controller shows up correctly in Gamepad settings though. I will look for some drivers.

I am having the same problem as he is.

I don’t think Win10 is the issue as the controller works fine in all other games. it is a KI specific problem

it has been weeks and still no word on a fix. this is huge issue for some people. I can’t play this game on a keyboard

Ironically, I was able to play the preview version of Shadow Lords before the last update and the controller worked fine.

Yeah, it was the last update to the game that did it. The win 10 anni. update isn’t the culprit. Fightsticks across the board were working fine after the anniversary update. But when they updated KI to support the crappy xb1 fightstick drivers it took away support for other fightsticks.

Are they going to fix this?

If I were to guess, I’d say a fix would likely be included in the next patch.

Yeah my controller doesn’t work anymore either. It was working fine since launch on PC (and even during SL Beta), but ever since the full SL patch it no longer works in KI (but works fine in other games). I really hope this is fixed soon!

1 Like

Any word on the next patch?

Not that I’m aware of. The only thing I’ve heard is that they are aware of the issue & working on it.

1 Like

Updated 3.5 has come and it still doesn’t work. :thumbsdown:

would be nice if someone official would at least acknowledge this issue

I haven’t been able to play the game in months

I haven’t been able to play the game since the Shadow Lords beta. I would have bought the definitive edition but no fix = no buy.

Version 3.6 released and still no fix.

Another SF4 Fightpad user reporting in here, and would love to see this fixed.

Hopefully this will not be omitted.

same pb here , can t play with my pad sf 4 xbox 360 , please dev , do something :frowning:

Hey, my SF IV pad is working again!! I am not sure what I did but I plugged it and tried to download the Madcatz Windows 10 drivers on the website.

I didn’t quite get them installed but got to the point were it said to insert controller. I already had my controller installed, I went to KI and it worked!!

I am not sure if it was fixed or what but boom! I haven’t been able to play since Sept!

1 Like

Just a heads up my Xbox 360 SFIV Fightpad works again after installing the Windows 10 Creator’s update.

I didn’t do anything new with the drivers. Looks like it was a Windows issue.