Mic always live on Killer Instinct Steam Version

interface
gameplay
bug
Tags: #<Tag:0x00007f6926ada070> #<Tag:0x00007f6926ad9e90> #<Tag:0x00007f6926ad9d50>

#1

Hi guys,

How come there is no way to mute or disable your mic on the steam version? It seems the steam mic settings are not followed so if your mic is on anyone can hear you and worst of all it doesn’t tell you.

I get that I can unplug my mic when I play KI but I use it to chat to people in discord and it sucks knowing people in online games can hear everything I’m saying.

I’ve ended up in many matches where people don’t know their mic is live or they’re put their mic on their desk next to the speaker not knowing its live those playing on laptops are the worst.

This was not an issue in the Xbox One version due to party chat.
This was an issue in the Windows 10 release but could be stopped via disallowing the mic for the game in settings.

But in the Steam release there does not seem to be anyway to sidestep it a few of us in Discord did some tests to try and stop it and failed.


#2

yes also we need ping indicator too pls auto disable the mic.


#3

Only @rukizzel can save us please good sir I beg!


#4

That’s how every version of KI is like. It is just a port of a XB1 game. The Win10 version doesn’t have MIC controls either. Basically if you don’t want it on, you’ll need to disable whatever sound recording device your computer is using.


#5

Fortunately, the Xbox One and Windows 10 versions did have ways to disable it via a sidestep if you read my post you would see I noted this. but this is an issue that needs to be corrected telling the end user just don’t use your mic is not valid. having the game follow the steam settings is not asking for much.


#6

What about using the mic for anything else while playing? For example streaming, on a call, or chatting on discord.
While what you say is true, it does not properly address this issue.
For the Win10 version at least there was an option to specifically disallow the KI app access to your mic, instead of disabling it over your whole computer. There really should be an option for this inside the game.
Side note, adjusting the Voice settings inside of Steam also do not take effect inside the game. Everyone still hears me.


#7

If this is actually true, that’s… really bad.

You can’t use the microphone volume slider specifically in Steam settings (or turn on push-to-talk with a button you won’t be using)? KI just ignores those settings straight up?

If so, that’s the type of thing that really needs to be fixed ASAP.


#8

No matter what you do with the Steam settings your mic is always live and there is no indicator of your own mic being live on my side for sure.


#9

@developers, you really need to look at this. This is a huge breach of privacy and the type of thing I wouldn’t fault anyone for instantly uninstalling the game over.

Fortunately, because it’s the Steam version, I imagine a fix to correctly apply the Steam settings could (in theory) be patched reasonably quickly without all the console certification time.


#10

I found a way to mute. I’m using an Xbox 360 pad with USB connection. Simply push the START button in character select screen. Silent as the night. But oh boy was this annoying until I found out.


#11

That mutes the opponent … but does it mute you?


#12

I have some suggestions how to have fun with KI voicechat

1.Play Russian hardbass/most obnoxious dubstep you find as loud as possible to make him mute

2.Use Morphvox program to sound like Gargos

3.Imitate fapping sounds to make him mute

4.Grab some chips from bag/barf in middle of getting wrecked to show opponent you dont give a damn.

If you want to disable mic, right click on the speaker icon near clock on the taskbar, select “recording devices”, find your mic and disable it. But it will disable it completely, in other games too.