Killer instinct PC DLC PROBLEM

character
bug
Tags: #<Tag:0x00007f74afe1b2b8> #<Tag:0x00007f74afe1b128>
#1

OK I’m royally MIFFED .
I bought Supreme edition for Killer instinct on the PC and everything was working fine.
BUT NOW FOR SOME REASON THE GAME DOESN’T understand that I should have all the character unlocked.
I’m blown away, I’ve come to the realization that it must be a problem on my computer (since on my way WAY less powerful laptop, thats also windows 10 i can boot it up and see that i have all the chars). But why doesn’t my PC recognize that?!? I have go so far as to reinstall windows 10 on my PC just to try and fix this. I’ve already contacted Microsoft who told me I couldn’t get my money back and inevitably told me to contact iron galaxy who has just completely ignored me. I need any answers here, do i have some setting wrong??? Do i need to check some box or install some software? Why the HELL is my game not functioning. Like the game recognizes that i have the supreme edition, when i go to the bundles screen and try to purchase a new bundle it tells me i already have the supreme edition. And when i try to purchase the character again through the supreme edition option it just immediately closes the payment option window. So, please please PLEASE if ANYONE could help me with this issue i would greatly appreciate it, i loved this game and would really like to continue playing it.

#2

Hey,

same problem here. Bought the Double Combo package yesterday. There should be season 1 and 2 charackters be unlocked. But i just can play S 1 fighters … Do you know a bug fix or did u get a response?

Geets

#3

How did you buy it? Gift card or through standard mean?

If you bought it with gift card, make sure your region in windows 10 control panel is matched with currency you used to buy.

I am from Poland, and I bought Supreme Edition with USD gift card, and I have to set my region to United States to see my characters.

That`s all I can help you.

#4

Im from germany and piad via PayPal.

I will try then tip with the region settings…

Thx for reply.

#5

Tried to change my region settings to US and restarted my pc. This tipp didnt solve the problem :cry: :cry: :cry: :cry: :cry: :cry:

#6

Bear in mind that your win10 region has to match currency you used.

#7

Use this link. Try this. It worked for me!

#8

We know your suffering, woke up today to see if I could play my maya, and only season 1 characters available.
Some people told us to change the region settings in windows 10 to match that of the current currency you used to buy and it should solve the problem.
Why is it that I have to do that again as the game has been working completely fine for the last 2 and a half months?
and regarding the tip above, my windows 10 is in portuguese - BR ( brasil ) and I bought the packs inside the game with my credit card and its the same currency as my windows and I still have that problem.
Some of my friends are playing and no problem for them whatsoever, however some of them didn’t get the supreme edition, I am starting to suspect that the problem is actually with the supreme edition of the game on pc, because most ppl with this only season 1 characters available problem seems to have purchased the supreme edition also.
I guess we are depending on the iron galaxy team to sort this problem, as it was probably introduced after an update, because, as I said before, the game ran fine or 2 months and a half, and I am with this problem for almost a week now.
And IG isn’t exactly known for their support… we are screwed…
IF I get any answer I will update in here. GL to us all

#9

Guys, I found a fix for my problem with the season 1 only characters being available to choose from even though I bought the supreme edition ( windows 10 only )

#10

Mumaki, here.

#11

Nightmare, here.

#12

Both me and @Jeffron27 are receiving the same problem too. Our DLC isn’t working.