Killer Instinct Definitive Edition not working properly

This seems like a joke to me Waiting a week for a solution to the problem and with the patch still not solved …

dude they’ll fix it. as far as a fighting game that fixes it’s issues, KI is bar none. go play MKX and deal with their broken crap for a year with crap net code. MKX uses a similar net code to KI now cause it’s so good.

Don’t even get me started on street fighter.

IG is the best when it comes to fixing stuff. this isn’t cod.

the lines of code just for one character has to be insane. and for each of those to play nice with other characters, is just stupid crazy.

Mortal kombat doesnt make me wait 12 days to get my content I paid 40$ usd for. you advertise something working, is should ■■■■■■■ work, when you find out it isnt, you pul it from the market, not let hundreds more buy it and feel equally ripped.

Don’t bother with the patch fellas, The one released today isnt our long awaited fix… too busy fixing unbalanced attacks…

hopefully well get a dev update on the issue

Well I would love for it to get fixed asap and then seeing posts like this

That doesn’t make me feel all to comfortable that they’ll actualy fix it in a reasonable time when it seems this issue has been around since October of last year. This may be diffirent issues in terms of the code I have no clue sense I’m not a programer but if people has had issues on Windows 10 since October in diffirent ways I find it hard to belive this will be fixed quickly. Hope the guys at IG can prove me wrong on this and that this will be fixed soon though.

So i went to a friends house and had him download KI on his Xbone and when i started the game up on my profile i had to go to downloads and download all the individual peices of the definitive edition like each character and season stuff, On my pc i did not download any of that all it had me download was the definitive edition itself with the artwork and stuff

1 Like

After downloading all the extra stuff on the Xbone i had access to it but not on my pc i think the pc version isnt actually giving you the downloads for some reason

In fact when you go to teh Definitive edition bundle On PC it says “In this Bundle” and only shows the base Killer Instinct and the Definitive edition which is the artwork and stuff BUT on the xbone it says “in this bundle” it shows all the characters and season bundles and stuff as well

naw. that post was for regular KI on PC. there was a issue obtaining an certain IP address but that’s it. completely different issue. heck, even Xbox bugs out and greys out characters. a reboot usually fixes it.

I i went to the Microsoft store and went to my Library, I clicked Show hidden games/ Show all and it shows all the stuff im supposed to have on pc like the killer instinct season 3 ultra edition and everything else including sepereate characters. BUT it shows a Exclamation mark On each product and says that it does not work on this device so the Definitive Pc edition does not unlock the stuff on pc only on xbone. Thats false advertising :confused:

Like this all these individual items downloaded on my friends Xbone but that was days after i puchased it on my pc, None of these items are downloadable on my pc

New patch! NO FIX! HOORAY! Silence? Check! Large pissed off community who BOUGHT the game only to be slapped in the face with lies? CHECK! Man things sure are checking out today, this is a great day for KI and all it’s fans /sarcasim

Sometimes things just don’t work properly, even with massive amounts of testing. Don’t worry, I’m sure they are working in a quick fix to help everyone affected.

i honestly have the HARDEST time believing that. It’s been about 3 weeks for me now since this has happened. Ive been with microsfot supp for HOURS on 3 diff occasions, they are useless, and only after like 2 weeks did dev even come on and say they had a fix, that clearly didn’t work. They put their tournament importance over all these people they cheated out of 40 dollars

1 Like

Its working for me now THANK YOU!

Hey Teddy, since Barag had the same problem and his works now with the update, try updating and try starting it again.

same here, it’s working! thank you…hunting now :smiley:

i checked like a bit ago and it wasnt working guess ill try again