KI on PC FPS dropping...any help?

Hey everyone. First time posting, long time KI fan, so forgive me if I’m posting this in the wrong spot. I have a question for anyone that’s been playing KI on PC. I have a (fairly) new gaming PC – Alienware Alpha that I bought back in June. All specs are up to date and my graphics card driver is current. My rig is:

NVIDIA GeForce GPU (ver373.06)
i7-4785T CPU @ 2.20GHz

I’m noticing I’m getting some occasional frame drops, mainly only when characters do shadow moves. I’ve gone up and down on the resolution but it still happens. While the game is still playable once that hiccup happens, it still can disrupt the flow an affect execution and combos (of course). Is anyone experiencing this and/or can help fix it so it’s not doing this. This was also happening with SFV on PC/Steam, but I was able to turn VSync off to get it running perfectly. I thought maybe I could turn VSync off with KI, but after doing research, with KI being a Windows Store app/game, you can’t turn VSync off, so that’s a bust. Any ideas/help?

Well ur processor is weak. What is ur GPU?

It just says I have a GeForce GPU from NVIDIA. One thing I just noticed is that my driver needs updating, so that may be the cause, so I’ll try updating it and try again. But this is what I got:

Cores 640
Base Clock 1019MHz
Boost Clock 1019MHz
Memory 2048MB

But I honestly don’t understand why this is just happening in the past month or so, primarily only when doing shadow moves, and doesn’t appear to happen on other games with similar requirements.

I did some research and found out that it may be a custom overclocked GTX 860m which is what I run. Try changing your settings to the following:

Resolution: 1920x1080
Motion Blur: Off
Reflections: Off
Ambient Occlusion: Off
Bloom: Off
Anti-Aliasing: Off
Shadow Quality: Low
Texture Quality: High

Your system should perform better. Also, yes make sure you’re keeping track of which updates for your GPU you are downloading. A couple have messed up KI’s performance for me.

Open the Xbox App > Settings > Game DVR > Turn it OFF

What should i clock my 960m too?