KI continues to crash at launch on PC

It’s been three days since the update rolled out and I’m still unable to play the game. I’ve reinstalled it twice and updated my graphics card to a Radeon RX 480 8GB card, and I’m still getting nothing. This problem needs to be solved ASAP. I can’t exactly keep supporting this game if I can’t even play it. >:I

Sorry to hear you’re having trouble; I recommend posting in the official bug reporting thread, since that is the thread most often looked at by the dev team. The more information you can provide (hardware information, error logs etc) the better.

It’s also worth noting that with the holiday weekend there’s no knowing how many dev staff will be able to look into it, I assume they will be off for a few days at least.

I saw the post you made in the linked thread;

If it’s giving you an access denied message make sure you’re logged in as an administrator, and that the KI folders aren’t set with restricted access.

I’d also try a full reboot of the computer, and verifying that your Location/Time Zone settings are set correctly; I know these various things have caused issues in the past (based on having seen posts) but I couldn’t really help you any further since I don’t know anything more than basic troubleshooting for this kind of issue.

That’s the thing. It’s not giving me an access denied message, it just crashes to desktop. I only found out about the access denial thing after looking in the event viewer. I’ll give it a try, though.

Getting the same issue with the crash immediately after the logo screen. I’ve tried the suggestions found in the forum but nothing seems to fix it. All drivers are up to date. Windows it up to date. But game continues to crash with the following spit out to the event viewer logs.

Massively frustrating that games can’t just work these days.

Faulting application name: KillerInstinct_UWPx64_r.exe, version:, time stamp: 0x5850f85f
Faulting module name: unknown, version:, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000000022dcab710
Faulting process id: 0x1f80
Faulting application start time: 0x01d25fec2e7201b6
Faulting application path: C:\Program Files\WindowsApps\Microsoft.KillerInstinct-Win10_3.6.0.0_x64__8wekyb3d8bbwe\KillerInstinct_UWPx64_r.exe
Faulting module path: unknown
Report Id: a369b423-1530-4e7a-a4f8-bf5627eb39c4
Faulting package full name: Microsoft.KillerInstinct-Win10_3.6.0.0_x64__8wekyb3d8bbwe
Faulting package-relative application ID: KillerInstinct.App

I’ve had this exact crash for more than a month following one of the Shadow Lords updates, game crashes to desktop after the IG logo, event viewer shows unknown faulting module, etc. I’ve tried everything I could find and no luck - even installing old Nvidia drivers one by one. I know normally that’s the point where the Xbox app tries to log in if you’re not, but even on a new user account with the FTP version and no Xbox account, same thing. None of my other Windows apps do this, not even Gears Ultimate.

Seems like more people are getting this after the 3.6 update so hopefully it’s getting noticed. I emailed IG directly and they said they would look into it and pass it on to the KI team at MS (hopefully there’s more word after the holidays).