Joining lobby issues

Hello guys,

today for the first time I have encountered an issue. I play on PC, a friend of mine on Xbox.
We usually simply invite each other and play without problems.

Today we have tried to create a lobby, and I could join the lobby he was creating but we coudn’t start a game, and I would be kicked out of the lobby with the message “One of your friends have left the lobby”. Same for him.

At the same time some random guys would be able to join the lobby and we would start fighting immediately.

Question: Do I need to open/forward some ports on my router - or is it a different issue?

Same here, for some odd reason i’m unable to join a lobby or fight online.

This has been an issue that I’ve complained about for well over a year, with very little returned in the way of an official response. Personally, I think it has to do with network connection speeds and stability more than anything (I play on Xbox One), since I always have the same issue when more than 4 or 5 people are in a lobby that I’m in. I believe the game artificially limits who stays and who goes if their connection basically can’t meet the game’s requirements for a smooth game. With that said, if you’re on a wireless connection, that’s your 1st mistake - while not exactly a solution, going wired has significantly helped me.

1 Like

This is my internet speed.

As far as I know, online gaming speed of 1 MBPS of upload speed is recommended. Since I have 2 MBPS of upload speed, not once have i noticed any lag on my end in street fighter, Call of duty, Smash Bros and MKX.

Happened a few times with me with lobby modes. Worst part is that we live together lol

I looked in privacy, router and network settings and it didn’t do much. I heard using a wire helps substantially, or limit the amount of traffic on a router. My issue is that my family will come over and suffocate the internet so it makes it tough to connect. I usually disconnect local devices as well to allow for a smoother experience.

After a while and the combination of all the methods, I managed to connect normally.

Not even with the Ethernet cable connection am i able to join a lobby. @ oTigerSpirit. I get that sometimes, but they know the rules of KI. no internet usage while i’m playing KI

Wow, is your NAT type at least Open? If so, I truly have no idea… I’d recommend Xbox Support, but they’d likely send you in circles.

It is. And yes, xbox support puts me in circles . I don’t know what to do.

Wow, I run at only 6MB/s down and 1MB/s up on mine (which is half of yours) with ~100ms ping for latency at any given time, and aside from the aforementioned lobby issue, I can play online just fine.

It works now, all i did was uninstall it and reinstalled it.