Help me please, disconnecting issue

Alright this is seriously getting out of hand for me.

When I play with random people through matchmaking its fine, I can do long sets with no issues, occasional lag freeze here and there, but stuff works.

But matches with friends from invitation or in lobbies are nightmare, game plays fine, no lags or minor, and suddenly game just decided to get massive lag freeze outta nowhere and game disconnects.

This occurs mostly in second match.

And weird thing is, I also have this issue with people I had played through matchmaking with no problems o.0

Please help, is there anything I can do about it? Its crippling my experience and embarasses me when I try to compete in online tournaments.

I am on Windows 10, my connection is 10mb/s (I live in village so I dont have many options, and if there are any, its expensive af), connected with ethernet cable to computer.

You should say whether you’re on xbox or pc, things can change quite a bit from on another.

also try forwarding your ports on your router if your on pc.
this may not be your fault anyway, sometimes the game lags
anyway, and I get 50 mbs.

Torrenting is not good when gaming. just saying…

Its possible that your connection experiences drops at those times, moments where it goes offline and then reconnects after long enough that the game considers it a disconnect. Happens to me with my â– â– â– â– â– â–  ISP.

1 Like

I spent all Saturday night making my NAT type Open and port forwarding on my Xbox and PS4. It made a huge difference. I definitely recommend this process. It can be some what complicated and technical but if you are smart enought o figure it out…its worth it.

my speed is back up to 121mps or more.


Yep, it looks like NAT issue cause I have closed one. I tried various guides and called my ISP, not possible in my place and offer I use currently. Im fked i guess.

Why wouldn’t it be available? You just clear Mac address in advanced setting and restart. If that doesn’t work use port forwarding in your gateway modem.

You using wifi or line connection?

the Xbox one ports are 84 and 1083 or something close to that. Ill see if i can find the link of the guide I used.

Please post this. I can’t find anything that makes any damn sense.

I used ports 80 and 3074

Write down tehIp address and the wired mac address under advanced setting in your Xbox…put those into your Modem gateway under port forwarding edit… set the ports to 80 and 3074

I just did a lot of reading and researching until it made sense. Its basically just 4-5 steps.

The easiest is just go to advanced settings…clear your Wired mac address and restart your Xbox… it will set it to Open… if that doesnt work, you have to go into your modem gateway and do as described above.

1 Like

I will try this. I have a complicated setup because I have a crummy Comcast modem that has to run to work our security system. I have a very good netgear router hooked up to that (wired). I have one Xbox wired directly to the Comcast router and one wired through hotline to the netgear router.

For the most part my NAT comes up “moderate” and I don’t have any problems. But once in a while it will lose its mind for a few hours and nothing works.

Mine was reading Moderate too. The reason I changed it was becasue we are supposed to have 150mps. At my old house it stayed in the 140-170mps range. But since we moved its been very inconsistent. Even drops to 1mps…then up to 127mps…but averages around 48mps.

I had Comcast come out and look at it and they were baffled. He tried to say Xbox one servers aren’t good for speed test or some ■■■■. So i thought about the NAT type and gave it a go. It worked and my speed was 127mps…but last night it was low again in the 37mps range.

Im not sure what the true issue is but I have to get i fixed because I dont like paying for something and not receiving it at least 98% accurate.

I have a similar experience. My 150 Mbps often equates to about 40 on the Xbox during a big download. I’m not entirely sure that it’s a problem on my end. It may well be that the servers are simply sending the information at 40Mbps. If I run the speed test in the Xbox normally I get something in the 130s.

EDIT: on the rare occasion it is dipping below 40 I reset the box and the Hotwire adapted and that usually does the trick.

Mine is dipping when nothing is downloading or using band width. I personally think its either the signal booster they installed or something outside on the panel box. But I never had this issue in my old house which is right next door to my new house.

I just want my 150 back… becasue now if Im playing on line nothing else can happen, no wifi on the kids Ipods, no net flix in the bedroom, no down loading a game update , ect… if any of those happens it struggles.

Sometimes its fine, but most the time wah wah wah wahhhhh.

For what we are paying I want Roadrunner speed!!! All the time! (You dont remember Roadrunner internet with time warner cable?lol)

I do remember roadrunner. I’m old remember.

That’s really weird because Netflix in HD wants about 20Mbps of your bandwidth and gaming really only uses about 2Mbps (it varies a little but you really aren’t receiving that much information). So even at 40Mbps you should still have plenty of bandwidth to let the kids do their thing…

It’s so aggravating to deal with this stuff and you bring in the supposed experts and they don’t know ■■■■. The MO is just to identify some other department to blame.

Your exactly right! They blamed the office for not putting the correct speed in my account folder or whatever its called, they blamed the sub contracted techs that came out and put in the first modem and booster. He wouldn’t even look at the booster even though is was by his foot.

Like i said it drops down to 1mps at times and then back up to 40, 70, 17, 121, …it jumps all around and I dont know why.

I dont really have any issues playing, but if she starts up netflix while Im on a down swing of the speed… it disconnects.
I used to play online, while watching twitch on my laptop and the net flix going in the other room! So this totally sucks.

Ugh. It’s only going to aggravate you if I try to troubleshoot through the forum, but I see something similar and it usually fixes it when I reboot the Hotwire adapter. For whatever that’s worth.

Whats the hotwire adapter? Is that your line connection through the AC plug?

My speed just dropped to 3.7 a few minutes ago so now Im about to call Comcast back out here. This is ridiculous.


EDIT: are you doing speedtests in the Xbox or on a PC?

Spped test on both…when i do PC its pretty much averaging 50mps…when I do the Xbox is jumps around as Ive mentioned…when I do PS4 its usually on 121mps.
I just hooked up my old Xbox one in my sons room to wired and it was at like 3mps and on STRICT NAT.
So frustrating because I downloaded all my KI files to his profile and Kilgore was installed but wouldn’t show up on his game as available.

I would like to ask mods to pin this thread or gather information from this thread in some kind of guide to help new players with any potential connection troubles.