Frustrating disconnects

So this happened to me several times now. I wanted to play a few matches on ranked and the connection between me and my opponent was so bad that the game was laggy from the start and by that I mean the opening cutscenes of the characters. Of course it doesn’t take long to freeze completely and send me back to the menu screen. Sometimes it happens mid-match completely out of the blue. As if this wasn’t frustrating enough I get a loss and I am stuck at 0 points :frowning:
Didn’t the devs say they had a system in place to distinguish between connection failure and quitters? If so, it’s clearly not working as intended.
Interestingly enough, this does not happen every match. Some are perfectly fine and lagfree which leads me to believe that my internet connection shouldn’t be the problem here.
Maybe somebody else shares the same experience and this gets looked into.

I already tried restarting the Xbox, did the multiplayer test in the network settings, my NAT type is open, everything seems to be fine but still no success. I’m pretty sure this problem first occurred after the Shadow Jago update.

Are you running wirelessly? I used to disconnect often with a wireless connection.

Nope, Ethernet of course. I should have mentioned that.

anyone else in the home running netflix, computer, streaming or another online game?
If not then it shouldn’t have been your disconnect therefor you shouldn’t have been credited as a loss…are you sure you were given a loss and lost points?

Yes, I get a message saying it counts as a loss everytime. And since I’m already at 0 points, I cannot lose any more :confused:
And no, there’s nothing else running that requires a lot of bandwidth.

It must be your internet then…its not the game. I have never had a disconnect that has given me the loss. I have the fastest speed Xfinity wired internet. 160mps though

I have 32 Mbit/s. Should be more than enough for online gaming. And like I said, it worked totally fine in the past.