Can't purchase Supreme Edition - or anything for that matter

When I try to purchase stuff in the ingame store, this pops up for a second: - After which it disappears and “Processing Premium Purchase Request” continues and eventually nothing happens…

Added both paypal and credit card as payment options and made sure they’re the same country as my PC is set to, so running out of ideas as what could cause this.

Anyone else with this issue? (And maybe with a solution?)

EDIT: Solved it by purchasing it on instead!

Haven’t seen this issue. Do you have filters on your browsers or have adblock enabled?

That would be the first thing I would check and if that still doesn’t work then try a different browser all together. If that still fails then it may be an issue on the department side and you may need to contact their support team.

Well it’s in the game - so not sure how browsers would affect it, nonetheless, I tried disabling ADblock, and still no luck

Ah, didn’t see that. Have you tried looking for the download separately, as in outside of the ingame store?

I have not - Can you buy them outside of the ingame store? (I may be an idiot here, my apologies)

Lol don’t be sorry, I’m pretty dumb myself. Maybe @rukizzel has more insight. Ah, just checked it out, I don’t think there is an option like that.

What are you trying to purchase? Assuming you’ve already gone through the machine restarts and all that, yes?

Got same problem, cant buy anithing

Pretty much - However, I went on the Xbox Live store ( and got it instead, works like a charm now :slight_smile:

I have the same issue on PC, i even made a topic about it yesterday: Error trying to buy from the KI Store PC

Yes , I did the same, but the price in Ilve store is a bit higher.