Cannot connect to Multiplayer Servers

Hi guys,

Since the anniversary update (i mean few days AFTER the Anniversary patch,) i cannot access to Multiplayer servers.
(Im on Xbox/PC)
I cannot play ANY multiplayer session. Exhibition, ranked, Lobbies, even ShadowLords MP doesnt work.
I don’t have any issues with Internet except with Killer Instinct.
I tried any “teredo fixes”. I unistall/reinstall multiples times.
I tried on Steam version. It worked, but i have none characters.
I can see the ranked leaderboards, but i cannot connect to MP servers to play online.
So my guess i have an issue with the PC version.

I always have this screen:

(it basically said: Error. Cannot connect to multiplayer servers. Please try again)
Anyone can help me or have the same problem?

Flagged this for our team to look at the MP issues.

Regarding steam- send me a DM about that. I will be offline rest of today but will respond tomorrow morning (pacific)

Could you also answer me about this? cause i’m having the same problem.

If you do not mind sharing, what Platform and region?
If windows, recommend all the usual troubleshooting of reboot, windows update and making sure there is not a firewall or antivirus or add blockers causing this. Note: Not giving any advice on turning any settings off here, recommending checking the Xbox official troubleshooting threads for this information.

This has helped many, but not helped some players, but it is the starting point.
You can message me directly with more information.
I will be a bit slow to respond but will get back to you over the next day.

I’m playing on windows, the steam version, in South America if it helps