Attention tech heads, I need suggestions! (Teredo IP problem)

Alright so here’s the deal: The wi-fi capability on my Xbox One is going out. It will randomly drop connection when it shouldn’t and sometimes is unable to rejoin my network.

I can’t run a 100 ft ethernet cable downstairs to the router because it would be super ugly and be a safety hazard.

Here’s my setup:

Cable Modem > Linksys EA6100 > (Wi-Fi) > Netgear N300 range extender > (ethernet cable) > Xbox One

when I run the network diagnostics, the statistics are solid (0% packet loss, 30ms ping, 60 Mbps download, 8 Mbps upload). However, when I run the multiplayer diagnostics, it says “Can’t get Teredo IP address”.

To fix this problem, I’ve tried powering off the modem, router, Xbox One, and wi-fi extender. I’ve even tried disabling and re-enabling UPnP on my router and power-cycling everything again and the issue continues. What’s strange is that when I connect my Xbox One wirelessly to the wi-fi extender, I do not get the Teredo error but of course the connection is spotty and unreliable.

The router firmware is completely up to date and I’ve even reset it to factory settings with no change. This issue happens wether I use my 2.4 GHz or 5 GHz wireless network. I’ve even tried a whole new router and the problem was the same.

I’m at a loss.

Update: Well, it suddenly started working (no Teredo IP address error) but I made no changes. Unfortunately, I still get the terrible connection drops. I’ve tried different networks, different routers, different settings and different configurations of connections and all have the same result.

Try using a powerline adapter instead of wireless. I know not a solution but it’s pretty much close to ethernet.

1 Like