[Windows 10] Fix for "Failed to reach matchmaking servers"

Hello fellow instinctual killers.

I simply wanted to share a fix that worked for me. I could not play online, because I always received the “Failed to reach matchmaking servers” message after a minute or so of search.

This fix is specifically for the Windows 10 version.

Now, the fix:

1) Type gpedit in the Search Windows bar.
2) Click on the only result you should get, namely “Edit group policy”. That will open the Local Group Policy Editor window.
3) From the two options you can click in the right field, click Computer Configuration.
4) From there, navigate to > Administrative Templates, then to > Network, then to > TCPIP Settings, and finally to > IPv6 Transition Technologies.
5) From there, at the bottom of the list, you should see Set Teredo State, double click that one. That will open the Set Teredo State window.
6) In that window, on the top-left you should see three clickable options, namely Not Configured, Enabled and Disabled. Click on Enabled.
7) Again, in that window, just bellow those three options, you should see a clickable drop-down list with four options to select. Select Enterprise Client at the bottom of that list, and don’t forget to Apply the changes (bottom right).

That’s it. Now just launch Killer Instinct, go in Multiplayer and try online matches (Exhibition, etc). The search for an opponent might still take some time, but it will work. Do note that after both you and your opponent select your respective character you might have a black screen for a moment just prior to the match starting, that might be a “normal” behavior for now. You will load the map and the match will start, just give it a few seconds before everything shows up on-screen (it might have something to do with the connections having to sync together before anything appears on-screen, but I’m not 100% sure about that).

Before doing that specific fix nothing worked for me. Additionally, I’d like to mention that nothing I did with (or without) Windows Firewall changed anything. However, if you do use Windows Firewall (or any other third-party security software) then obviously make sure that Killer Instinct is at least authorized. Other than that there’s nothing else to do, it’s very straightforward, and there’s no need to type any fancy commands via CMD Prompt either. Well, at least it worked for me. If this method does not work for you then I’m sorry but I wouldn’t be able to offer assistance, because everything else I’v seen myself was found via Google (and nothing I found there worked, until I found out about this fix here which I’ve seen posted somewhere else on another forum that has nothing to do specifically with Killer Instinct, but was merely about general gaming).

Hope it helps, just wanted to share this.

I’ll be trying this out once I finish redownloading KI on my PC, and I hope this will work. Tried about every ‘fix’ there is right now, and nothing’s worked yet, even after reformatting windows (why I have to redownload), which is pretty frustrating because how much I like playing the game. I’ll edit this post once I’ve given it a shot.

I dont have a TCPIP settings in my Admin Templates > Network… I have Windows 10 Home 64bit, which originally doesn’t even HAVE the gpedit.msc initially. I had to dig around online and find a method for adding it… So perhaps that’s why?

Do you know a work-around for this or anything? Ive been trying the last several hours to make KI work and its simply not doing it. It seems to flat out refuse to connect to anyone. Random matches, or specific people.

Originally it would just search forever, or in the case of specific invites (Thank you for your patience Galactic Geek!) it would just give a failed to connect message - now its saying it cant reach the match making servers. I came across this post while searching for solutions.

Edit:

Ive tinkered around and found I can set Teredo parameters via command lines. I set my type to Enterprise Client, etc… but if I scroll down the list of Teredo paramters… I see

NAT : none (Global Connectivity)
NAT Special Behavior : UPNP: No, PortPreserving: No

I dont know enough about what Im doing with this stuff to know if this is ok, or bad, or what. UPNP is ENABLED in my router.

You can get to these parameters by going to Search and typing Cmd, then typing:

Netsh Int Teredo Show Stat

If anyone who’s KI WORKS could do this and list exactly what your NAT parameters are, I would really appreciate it. Thanks folks.

The group policy editor isn’t available on Windows 10 home systems, which is what most people have. So unfortunately this solution isn’t viable for anyone who doesn’t have Windows 10 professional.

I was able to set up gpedit on my PC but the TCPIP settings folder isn’t there. I’m not sure what to do now