Unable to buy Bundle (Solved)

So I have the base game up and running but I need a bundle. So within the game I went to store and attempted to purchase a bundle but it comes up with some message that something went wrong, try again. I already have my CC attached to my account.

Anyone know what I can do? Is there a work around?

Wait, make sure you didn’t already purchase. Look if you got a confirmation. Next I would say check if the Xbox Services to see if the store is up and working properly. Not sure if the same services apply to the Windows Store though.

It’s not just with this game, every single game I try to purchase comes back with this message:

Give it another try

Something went wrong

2016/03/31 0 07:38:39 UTC

At least im not alone. Having the same problem. I have made a thread about it in general discussion. My friend, exactly the same set up as me can purchase anything . I have the something went wrong error with the hexademical error code

I fixed it.


  1. Sign out from your current Windows 10 Account

  2. Create a new Windows 10 User Account and give it Admin access

  3. Login to the new Windows 10 Account then open up the windows store or in this case, Killer Instinct, it will prompt to enter sign in details, enter the sign in details for your original Windows 10 Account with the added payment options.

  4. Then go to the ingame store and purchase the bundle.


This worked for me. After I just switched back to my main windows 10 account. This just a workaround not a real solid solution as we shouldn’t have to do this every time we want to buy something from the windows store.

Above all make sure that your region and language on your User Account matches the one in the Windows store.

Well after a lot of frustration and to avoid breaking my pc i formatted .I ll take from scratch without any
extra security programs and ill go from there. I have already did what you mentioned but no results.
I m from Greece win 10 are authnticate english region have selected Greece and you told me to go to my
ms account which i sign in with win and in properties to change there also my address to Greece?
Do i have to have a payment method checked to work or it will promt me inside KI?

it will prompt you to add a payment method ingame if you don’t have one connected. Region and language yes, they should match the one on microsoft store.

Try this then do all those steps I mentioned above, by signing out of your current windows 10 account I mean you create another one, with new fresh settings and then login to that, so there will be no previous files from your main user on the new windows 10 account. And stay signed into it as you enter the game through the windows store app, and then add payment using your main windows account not the new one you just created.

If not, try this. After you do this, repeat the steps above.


In old Control Panel / Internet Options / Advanced, make sure “Do not save encrypted pages to disk” is turned OFF. Then the Windows Store should allow purchases normally.

Made an account just to say thank you man, this was driving me nuts and changing that one little detail in my internet options seems to have solved the problem entirely. I had the same issue where you get the “try again” error on buying one of the bundles, or anything for that matter.
You saved me a lot of frustration.

Well i have 5 hours playing with all characters from season 1 &2
What i did was to format this god damn thing. And install killer after drivers had been installed
for system nothing else. Ti played right away. I had logged in with a microsoft account firstly.
The weird thing was after the purchase i had no problem neither with comodo firewall nor with avira
even with defender closed win firewall closed (ok that way couldnt play vs online but i could still purchase things).
Even try to buy something with a local account and still could.
I dont know what was the problem but i know it works!!!

@ShinChan22 weird thing is that this option is alaredy unticked by default, why you had it enabled?

I have no idea, I’ve never bothered with any of those settings before because I thought it would only affect internet explorer lol.