PC Issues Thread

Game is crashing when I try to load up my downloaded content, not sure why.

I can’t use an Xbox One fightstick to play the game on PC.

Hurry up with the drivers please.

Click Start -> type services.msc

Locate the download optimization (it’s called something like that), disable it.

Reboot.

Try again.

That worked for me.

My issue:

After getting past the DLC check on start up, and playing a few matches local vs CPU, the game crashes.

Happy to provide event logs etc if anyone from IG wants them.

Yes, I dont want them to change it. They need to limit the FPS to 60. They already looking into it.

Do you mean Delivery Optimization service? I disabled it but it didn’t help, still getting same error.

Thanks though.

Edit: Solved the problem, I had to disable Deferred Upgrades in Windows Update.

The issues I have are not specific to Killer Instinct, but limitations to the platform (including the 144hz issue).

EDIT: Read in other threads where Geforce Experience/Nvidia control panel may actually apply settings to the game, so I’ll test that out when I get home and see if that gets around the monitor issue. Also was pointed in the direction of where you can change the default location of windows store apps in the windows control panel under storage. Again, I’ll test that when I get home and if both of these things are avoided I’ll just delete this post.

1.) Because KI on PC is a windows store app, it is forced into borderless windowed mode, which means it uses the refresh rate that you have set on your desktop outside of any games/programs. Those of us with 144hz monitors are out of luck until the platform has a way to either make the apps run in full screen or come up with some other way of fixing this. For the record, Street Fighter 5 allows you to run it in 144hz refresh rate but keep it locked at 60fps, so the limitation again is the Windows Store platform and how apps have to be written.

Side note about the workaround: I saw the KI twitter account say the workaround is to change your desktop refresh rate to 60hz, which does get around the problem as KI will go off of that refresh rate and play at normal speed. However, with a lot of newer gaming monitors (mine specifically is the Benq XL2430T), ultra low motion blur is a feature on a lot of these that helps with moving images appearing sharper by strobing the backlight along with the refresh rate instead of the backlight being on 100%. This means changing the refresh rate of my monitor to 60hz makes everything way too dark as the backlight is strobing less than half of the frequency than 144hz. Do I really have to disable ULMB in my monitor and change my desktop refresh rate to 60 just to play KI as it was intended? Again, not a fault of IG here, but of the platform.

2.) Windows Store apps don’t seem to have a way for me to specify where I install them without a registry edit I found searching online. While most people may not have much of an issue with this, those who have a very common setup with their PCs with a smaller SSD for the OS to run fast then keep everything else on a larger mechanical hard drive, KI is over 21GB to download and I can imagine that would fill up many peoples SSDs unless they invested in a larger one for their OS. You shouldn’t have to edit the registry to change the default install location of a program, that’s just silly imo.

Yeah, that’s the one. Sorry, wasn’t near a Win 10 box at the time to get the name right.

Glad you got it working.

This post was flagged by the community and is temporarily hidden.

1 Like

Post match screen has “Missing text” line where opener ratio, average combo damage and the other stats should be.
The lockout icon doesn’t appear when getting counter-broken.
Some random crashes in ranked queue, just as an opponent is found.

Cant select theme music and background in practice mode. I own season 2 ultra edition but only some characters from season 1, does that matter?

My issue is that apparently my PC isn’t good enough to play this game even on low settings. What PC’s was this intended for? My PC should be able to run games like this no problem.

Is it just bad optimization?

EDIT: Nevermind, the game runs fine now after reinstalling it. Weird.

New Windows 10 player
As seen here

Do you have an eta on when compatibility with PS3 sticks like my Hori Fighting Stick 3 whether through drivers, white listing or whatever will arrive?

I have to settle for Joy2key or xpadder but those add input lag to the game with all the converting stick button presses to key strokes then sent to the game.

No it doesn’t - OBS works perfectly with KI - you can’t use ‘game capture’ - you have to use ‘monitor capture.’

OBS works with my Computer, you mean. What if I don’t wish to capture my entire monitor? I have auxiliary programs running I don’t wish to broadcast to the world.

Specs?

This post was flagged by the community and is temporarily hidden.

What are your PC specs?

This post was flagged by the community and is temporarily hidden.

You play KI in fullscreen, don’t you? Don’t start recording/broadcasting when KI is not running, only start it after. I think the hotkey is alt-f12. Hit alt-f12 again before you quit KI. Easy peasy.