New update 26GB?

Did they change his retro face to where it’s not so laughably bad?



:sunglasses:Do tell…

Well he looks I guess less goat face?

Seems as though we’re having to reinstall the entire game, so maybe there are some more optimizations in the update. Usually those kinds of big things require a full reinstall.

1 Like

First game in a while I had to wait an entire day to download.

I looked it up, he’s 9ft but you were close actually.

Ugh…the install for PC was too large for what precious little space I had left on my SSD, so it canceled the download, and now it’s having to download again…

Pretty sure this update includes shadows lords mode. I booted up the game before the download was finished and it said shadow lords at the top of the list above single player. I will upload the screenshot I grabbed soon.


Thanks can’t wait tho try the SL. Also is it me or are they colors washed out?

Did you open it?

1 Like

Tried to but the download finished and the game froze. Restarted and it was gone. :-\ and yea I have noticed the colors seem a bit washed out.

Man I’ve been downloading it since 6:30pm est and it’s still not done 35%

Going crazy slow for me. Been going all day, only at 45%

It can’t just be Raam it has to be more in this download because you can download just him as a fighter update. It might not be KI I tried installing other games too and man it’s taking forever to get to 30%

technically his height has never been officially stated. assuming you looked on the gears wiki the height listed has fluctuated between 9 and 10 feet for years

Looking through his costumes and retro costumes I’d say they did their homework for him as much as they did for Arby…after all, his retro doesn’t include a hawiian shirt, shorts, and sunglasses, so my guess is they took his representation rather seriously.

Thank god for that. I hate silly costumes.

1 Like

The update reached 9 Gigabytes. I shut down the PC and the following day, when I restarted it…surprise, the KI update, after indicating it was still at 9 GB, it went back to less than 1GB. Just wtf?