MIXER account help!

@rukizzel @TotalJimkata @BigBadAndy @TheNinjaOstrich and @ anyone that might can help me here.

Ok so I have a Mixer/Beam account and a few followers but I rarely Stream with Mixer but regardless I have a fully fledged channel, ect…
Now my son wants to stream and I got him a Kinect, headphones ect… and he is ready to stream. I made him a MIxer account so he can easily say Xbox broadcast and boom…he is streaming.

But now I cant log into my FallofSeraphs76 account. When I do it logs me into my sons account. Both have separate email logins and passwords. Not even close. The only similarity that I can think is causing this is both Microsoft/Xbox accounts are on the same 2 Xbox’s. Which shouldn’t matter IMO.

Any idea how I can fix this or where I went wrong? If I use Aidens log it goes to his channel…if I use my FallofSeraphs log in it goes to his channel.

Thanks…BTW I sent a message to Mixer, just waiting on a response.

I guess it doesn’t matter since I use Twitch, but I still would like to get it sorted out so I can use my Mixer account if I ever decide too.

I don’t know. Make sure he’s logged out. Maybe even take his account off the Xbox for a bit and see what happens. There should be a way to log out and back into Mixer… I just don’t know what it is.

I was doing this all on my lap top…neither Xbox was on. I made his account and searched for my account and “followed me”. Then I logged him out…tried to log into my account to “follow” my sons new account. But when I logged into Fallofseraphs it just kept bringing up Aidens account…now matter what I did. Which is odd since they are 2 totally separate logs and pass.

Owell… he is streaming TMNT right now and having a blast. Got his headphones, gaming chair and huge TV. His sister is his side kick lol…she just got done beating 3 shrines in Zelda BOTW… she is almost as far as I had gotten back on the WIiU.


1 Like

I got it to work! I changed my Mixer password twice… and now I can log into both accounts with no issues…not sure why changing my password matters but it worked.
Thanks everyone!

1 Like