Can't launch KI since new update

Since i downloaded the season 3 patch earlier today i have not been able to access my game at all. It keeps crashing on the checking dlc screen. I have uninstalled and reinstalled the game twice today and still cannot access it. Im extremely sad because i was looking forward to playing it so much today and now i cant even get into the game. I know a few other people in streams today were saying they have the same problem

1 Like

Try switching to another account. It worked for me.

Did it work for your main account afterwards?

I haven’t tried yet. I will try tommorrow.

I’ll definitely be trying that when i get home from work, thanks fam

I have the same problem here, the game crash on searching dlc screen. I deleted my save file and synch again with cloud and nothing, reinstalled the game and nothing. THen I created a new user on my xbox and it works.
I think the problem is with the save file that maybe got corrupt with the update or something. Hope we get a fix soon.

It didn’t work on my old account.