Bought Supreme Edition (PC) can't access the characters

As the title says I just bought the game and The Supreme Edition with all of the characters, costumes, etcetc, about two days ago. However, while the KI money is on there and the current/classic costumes, I am unable to access ANY of the Season 2 or 3 characters! And for some odd reason the in-game store thinks that it’s Christmas is has an old promo for Christmas icons and costumes up. When I start the game it checks for downloadable content but doesn’t give me an error code or anything and let’s me play. But when I go to ANY character select screen all the characters minus S1 are locked and tells me to purchase them WHILE saying that I already have the Supreme Edition.

I’m so confused. Is this a bug? Do I need to install something? Please help! D=

Reinstalling won’t help, I tried it multiple times.

Also @rukizzel

So, people have been saying this is because something in your Windows settings is not correctly finding the server clock. There was a fix somewhere posted here that seemed to work for a few people, I’ll try to track it down.

1 Like

I was experiencing this with Windows. My clock/TZ was off. I fixed it by just letting Windows reset the <a href=>clock.

Are you a Linux user? Since Linux manages its clock differently, when you switch back it Win10, it screws up the clock and thus screws up the characters.

Thank you, any help is appreciated. I just got this new computer (Windows 10 Included) less than a week ago so I’m not sure what it s.

I’m pretty sure I’m not, but for some reason the clock when I got this computer was off by an hour. I corrected it but the time on my skype and websites still says it’s an hour off.

Did you correct it (as in did you personally go and fix the time)? Or did you let Windows correct it?

If the former, then follow the link in my last post (the word “clock” since it is hard to see), and let Windows handle it. If the latter… I’m at a loss, and to be honest I’d probably contact MS customer service.

Initially I corrected the time manually before I downloaded the game. So maybe that could’ve been it? I’m reinstalling the game now (almost done) and I set the clock options back so Windows 10 just handles everything now so I’ll see how it goes in a minute.

Yeah, the internal clock was the issue. I just set it back and let Windows 10 run it automatically. The time on it is off by an hour but my game and all the content works so that’s a relief. Thanks guys for taking the time to help me.

You should be able to fix the time too by setting your timezone + “auto adjust for daylight savings”. That should all be in the link above too.

You can feel free to add me on Steam (qspec) or xbox (qspec02… I think… Steam is best), and I can help walk you through it if that doesn’t fix it.

Ah yeah, you’re right, I managed to fix it. Thanks man, I’ll add you on Steam anyway, you’ve been really helpful.

1 Like

I told you to do this in another thread lol